非凡OK网

专注优质网络资源分享的技术网

一个有趣的编程项目:基于JS且IDE、教程、包管理器都有的文言编程

一个有趣的编程项目:基于JS且IDE、教程、包管理器都有的文言编程

admin2个月前500℃

详细介绍

GitHub:https://github.com/wenyan-lang/wenyan

官网:https://wy-lang.org/

在线IDE:https://ide.wy-lang.org/

知乎相关介绍:https://zhuanlan.zhihu.com/p/112650761

知乎上看来一下相关介绍,不的不说这样的 代码很有趣,读起来朗朗上口。

这样硬核的编程语音,让文言文学渣没活路了。

Helloworld

文言:

吾有一數。曰三。名之曰「甲」。
為是「甲」遍。
吾有一言。曰「「問天地好在。」」。書之。
云云。

等同于以下 JavaScript:

var n = 3;
for (var i = 0; i < n; i++) {
console.log("問天地好在。");
}

输出:

問天地好在。
問天地好在。
問天地好在。

标点符号和换行都是可选的(就像古汉语中文字是连续的),所以上面的代码等同于:

吾有一數曰三名之曰「甲」為是「甲」遍吾有一言曰「「問天地好在」」書之云云

更多复杂的例子,可以在 ./examples 中找到。比如,埃拉托斯特尼筛法、快速排序、曼德博集合、汉诺塔。

特点

  • 符合古汉语语法的自然语言处理程序

  • 可以编译成 JavaScript,Python,或者 Ruby

  • 图灵完备

  • 在线 IDE,即刻体验

  • 通过几个例子快速入门

安装编译器

使用以下命令安装本编译器:

npm install -g @wenyanlang/cli

尝试运行内置的例子,例如:

wenyan examples/helloworld.wy -o helloworld.js


推荐阅读:

《高术通神》(精校全本TXT下载)作者:伸笔码良

《群芳承欢录》(全本小说TXT下载)作者:庄朝仁

网易云课堂 Unity制作商业级手游

朴有天谈吸毒丑闻后撒谎的原因 当场流下悔恨的泪水

我把孩子缩小了!黑曜石新作《Grounded》一天演示

EA Origin开启“数字游戏特卖” 多款游戏打骨折促销

文章下方广告位

网友评论

随机文章
热门文章
热门标签
最新留言